• Angry
  • Awesome
  • Hungry
  • Secret
  • Results 1 to 5 of 5

    Thread: Power issue Tata Safari 3.0 L 4*4

    1. #1
      not aware that he can set his status here!
       
      Awesome
       

      Join Date
      Nov 2017
      Posts
      4

      Power issue Tata Safari 3.0 L 4*4

      Hello everyone!

      I have recently bought a used Safari 3.0 L 4*4 and facing issues with power. After reaching certain temperature, check engine indicator lights us on the driver console and vehicle looses the turbo power. on pressing full throttle the push that vechile takes after a few seconds fails and vehicle continues with the same speed. It starts happening after 15-20 mins when engine starts heating up running for a few kms. Resarting the engine solves the issue for a few more minutes but again the check engine indicator lights up and vehicle looses accelaration.
      Has anyone come accross this issue. Could someone guide to what the problem is and possible solution.

      Thank You.

    2. #2

      Vroom ... Vroom
       
      Awesome
       

      Join Date
      Jul 2012
      Location
      Kochi
      Posts
      234
      How old is the car, whats the mileage on the ODO?
      Skoda Octavia 1.8 TSI AT 2017
      Honda Brio Vx AT 2013
      Volkswagen Jetta 2011 Code6 DSG/TCU tuned
      Ford Fiesta 1.5 TDCI (2011) Code 6 tuned
      i20 CRDI ASTA (2009) Pete's box

    3. #3
      not aware that he can set his status here!
       
      Awesome
       

      Join Date
      Nov 2017
      Posts
      4
      Quote Originally Posted by maverick-seby View Post
      How old is the car, whats the mileage on the ODO?
      180000 kms, Sept 2005 model

      Sent from my Lenovo A7020a48 using Tapatalk

    4. #4
      not aware that he can set his status here!
       
      Awesome
       

      Join Date
      Nov 2017
      Posts
      4
      Quote Originally Posted by Bhupindersharma View Post
      180000 kms, Sept 2005 model

      Sent from my Lenovo A7020a48 using Tapatalk
      I am not sure with the mileage, will have to check

      Sent from my Lenovo A7020a48 using Tapatalk

    5. #5
      not aware that he can set his status here!
       
      Awesome
       

      Join Date
      Nov 2017
      Posts
      4
      Quote Originally Posted by Bhupindersharma View Post
      I am not sure with the mileage, will have to check

      Sent from my Lenovo A7020a48 using Tapatalk
      I got it scanned and mechanic told me its EGR issue that creates vaccum is not functioning proplerly. Finding an old spare is rare to test the theory and just replacing it if doesn't solve the problem is a waste of money.

      Sent from my Lenovo A7020a48 using Tapatalk

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Replies: 22
      Last Post: 15th Nov 2017, 16:09
    2. Replies: 10
      Last Post: 21st Jan 2015, 15:41
    3. Tata Safari 3.0 losing power with headlights on
      By Aashay in forum Safari/Storme
      Replies: 8
      Last Post: 22nd Oct 2013, 09:24
    4. Santro Power Steering Oil Leak Issue
      By VinayReddy Reddy in forum Santro
      Replies: 10
      Last Post: 29th Jan 2013, 07:59
    5. Baleno - Power window issue
      By bbllaazzee in forum Baleno
      Replies: 4
      Last Post: 1st May 2011, 14:20

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •