• Angry
  • Awesome
  • Hungry
  • Secret
  • Page 1 of 2 12 LastLast
    Results 1 to 10 of 14

    Thread: Ikon Brake not working in the morning

    1. #1

      ...
       
      Awesome
       
      jaguar's Avatar
      Join Date
      Dec 2009
      Location
      Bangalore
      Posts
      1,880

      Ikon Brake not working in the morning

      Sometimes when I start the car in the mornings, I feel the brakes not working upto the mark. It feels as if there is not much play and the brake pedal is stuck. A few pumps to the brake pedal solves the issue and everything is normal afterwords. It is only in the mornings that I generally face this issue, but coming to think of it, it has happened at other times, very very rarely though. Could this be just the fact that the brakes are not warm enough or something like dust? I am worried if this is an indication of a major issue.

    2. #2
      Forum Leader
      Diesel till I die!
       
      Awesome
       
      Ripper's Avatar
      Join Date
      Oct 2009
      Location
      Cochin
      Posts
      2,821
      My first braking in the mornings is usually poor.
      I've no idea why. I've noticed a thin film of rust on the rotors in the morning, especially if i've been splashing around in puddles immediately before parking. Maybe that needs to be scrubbed off before the pads can bite.
      When I feel them slipping at the 1st application, i lift off and brake again. Problem fixed.
      Cant explain the lack of pedal travel in your case though.
      Please subscribe to the #Cochin hashtag for notifications on the Cochin meets.

    3. #3

      ...
       
      Awesome
       
      jaguar's Avatar
      Join Date
      Dec 2009
      Location
      Bangalore
      Posts
      1,880
      Quote Originally Posted by [url=http://gearheads.in/post28511.html#p28511
      rippergeo » Thu May 06, 2010 3:36 pm[/url]]
      Cant explain the lack of pedal travel in your case though.
      I need to keep a close eye on it and determine if the lack of play is for real or just my head.

    4. #4

      On the lookout for more 4
      wheel victims.
       
      Hungry
       
      tadukuttan's Avatar
      Join Date
      Oct 2009
      Location
      Bangalore
      Posts
      4,992
      I guess it is just the car "running out" of brake vacuum, once it has been stopped for some time. The pedals do become hard when that happens.

      Once you start the car, the right pedal feel should come back instantly?
      In pursuit of happiness, and happiness drives very fast.

    5. #5

      ...
       
      Awesome
       
      jaguar's Avatar
      Join Date
      Dec 2009
      Location
      Bangalore
      Posts
      1,880
      Quote Originally Posted by [url=http://gearheads.in/post28519.html#p28519
      tadukuttan » Thu May 06, 2010 4:02 pm[/url]]
      Once you start the car, the right pedal feel should come back instantly?
      This happens not exactly at start, some 50/100 meters after the start.

    6. #6
      not aware that he can set his status here!
       
      Awesome
       
      Frankenstein's Avatar
      Join Date
      Nov 2009
      Posts
      2,222
      Jag do you idle your car in the morning,if not idle the car for 5 minutes before going out.

    7. #7

      On the lookout for more 4
      wheel victims.
       
      Hungry
       
      tadukuttan's Avatar
      Join Date
      Oct 2009
      Location
      Bangalore
      Posts
      4,992
      [quote=[url=http://gearheads.in/post28520.html#p28520]jaguar » Thu May 06, 2010 4:06 pm[/url]]
      Quote Originally Posted by "[url=http://gearheads.in/post28519.html#p28519
      tadukuttan » Thu May 06, 2010 4:02 pm[/url]":965qu315]
      Once you start the car, the right pedal feel should come back instantly?
      This happens not exactly at start, some 50/100 meters after the start.[/quote:965qu315]Hm, suggest you get it checked!

      Quote Originally Posted by frankenstein
      Jag do you idle your car in the morning,if not idle the car for 5 minutes before going out.
      5 minutes? Not really required. 30 seconds to a minute is more than enough.
      In pursuit of happiness, and happiness drives very fast.

    8. #8

      ...
       
      Awesome
       
      jaguar's Avatar
      Join Date
      Dec 2009
      Location
      Bangalore
      Posts
      1,880
      I think I'll better get it checked. And I do idle for about a min in the morning.

    9. #9
      not aware that he can set his status here!
       
      Awesome
       
      Frankenstein's Avatar
      Join Date
      Nov 2009
      Posts
      2,222
      Might be you have a loose fan belt or some tensioner is gone kaput.

    10. #10
       
      .
       
      Awesome
       
      MechaniX's Avatar
      Join Date
      Oct 2009
      Location
      Bangalore
      Posts
      662
      It feels as if there is not much play and the brake pedal is stuck.
      You mean brake pedals is hard to press? if so, then brake booster might be having some trouble. Does your car idle fine when this happens ?
      If it Ain't Broke...Break It! Make It Better!

    Page 1 of 2 12 LastLast

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. 3G on BSNL. Is it working for you?
      By tadukuttan in forum Electrical and Electronics
      Replies: 47
      Last Post: 14th Nov 2010, 14:15
    2. Tyres for my Ikon 1.6 Zxi
      By rsandeepmoses in forum Ikon
      Replies: 15
      Last Post: 7th Jun 2010, 03:38
    3. VW polo or Ford Ikon or i20
      By bragha.88 in forum Hatchbacks
      Replies: 8
      Last Post: 1st Jun 2010, 00:59
    4. Ikon A/C Issues
      By jaguar in forum Ikon
      Replies: 5
      Last Post: 5th Apr 2010, 00:23

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •