• Angry
  • Awesome
  • Hungry
  • Secret
  • Page 4 of 4 FirstFirst ... 234
    Results 31 to 35 of 35

    Thread: Will Fix Ikon issues

    1. #31

      Maruti 800/Ford Ikon/Audi A4
      (99)/Maruti Alto K10
       
      Awesome
       
      Hemant Saxena's Avatar
      Join Date
      Jul 2011
      Location
      Mumbai/Bangalore/Vadodara/UK
      Posts
      16
      Quote Originally Posted by catalyst_delhi View Post
      send me your email address - i will wetransfer the manual
      bro, could you email me the service manuals as well as the owner manual if possible? I lost my owners manual at some Ford ASS.
      ~Be sober, be vigilant, because your adversary - the devil, walketh around seeking whom he may devour~

    2. #32
      not aware that he can set his status here!
       
      Awesome
       

      Join Date
      Jan 2016
      Posts
      1

      Question Jerking problem in my Ford Icon 1.6 ZXI (Petrol)

      Sir, I havepurchased this used car in 2013. Excellent Car , Make 2005.

      I am facing"Jerking" issue in my car with a little bit of race going up &down after I start my car.
      From last 5 days theJerking has gradually increased now even on 5th Gear.

      My Mechanic saysthat he needs to check the car & I should leave it with him for whole day.He said there may be multiple issues & he will have to do the analysis thatwhich Parts needs to be replaced. According to him:

      • there can be issue in IAC Coil.
      • It can be Injectors
      • It can be anything……

      According to his words,I felt like he wasmaking me clear that there might be some big expense for which I need youropinion.


      Can you please sharethe possibilities/reasons that can resolve this? And what could be the possible expense in getting this resolved?

      And can you shareMANUAL in ENGLISH.

      Many thanks
      Vikas

    3. #33

      NO ONE CAN PREDICT WHAT'S NEXT
       
      Awesome
       

      Join Date
      Oct 2011
      Posts
      183
      do you have any idea for ford ion tdci its horns are not working and the fuse is ok
      " DRIVE SAFE "
      THERE IS SO MUCH TO SEE IN LIFE , THAT ONE SHOULD NOT WASTE IT BY MAKING SILLY MISTAKES AND REGRET LATER ..

    4. #34

      "Take a deep breath It's
      Just a BAD DAY, Not a BAD
      LIFE"
       
      Awesome
       
      Queensyrche's Avatar
      Join Date
      Apr 2016
      Location
      Kochi
      Posts
      429
      Quote Originally Posted by Vikas6788 View Post
      My Mechanic saysthat he needs to check the car & I should leave it with him for whole day.He said there may be multiple issues & he will have to do the analysis thatwhich Parts needs to be replaced. According to him:

      there can be issue in IAC Coil.It can be InjectorsIt can be anything……
      According to his words,I felt like he wasmaking me clear that there might be some big expense for which I need youropinion.


      Can you please sharethe possibilities/reasons that can resolve this? And what could be the possible expense in getting this resolved?
      vikas6788, Did use the 1.6 for around 4 years. Amazing car and torque I recon

      Even I faced a similar kind of issue and the diagnostics were very similar. As far as I know, it could be either the Ignition coil or Dirty / busted Injectors

      Ignition coil - around 5-6k if I remember correctly when I got it fixed
      Injectors - Mine was just dirty and just had them cleaned - 1K

      Hope this helps.

      Cheers,
      Queensyrche
      2014 Kawasaki Ninja 300R
      2011 Ford Figo 1.4
      2012 Tvs Wego

      2009 Ford Ikon 1.4 | 2006 Ford Fiesta 1.4 | 2003 Fiat Palio 1.9
      2002 Hero Honda CBZ | 2002 Ford Ikon 1.6 | 1998 Ford Escort 1.8

    5. #35

      "Take a deep breath It's
      Just a BAD DAY, Not a BAD
      LIFE"
       
      Awesome
       
      Queensyrche's Avatar
      Join Date
      Apr 2016
      Location
      Kochi
      Posts
      429
      Quote Originally Posted by sharatbali View Post
      do you have any idea for ford ion tdci its horns are not working and the fuse is ok
      sharatbali, Switch of the engine and open up the hood. Plz check the wiring loom going to the horns. Investigate if these wires are cut or loose, where it get plugged in to the horns.

      If you have a person to help, ask him / her to try and honk when you are making adjustments to the plugins. It might just be a loose connection.

      If these things didn't work, please do take the car to a car electrical shop.


      Cheers,
      Queensyrche
      2014 Kawasaki Ninja 300R
      2011 Ford Figo 1.4
      2012 Tvs Wego

      2009 Ford Ikon 1.4 | 2006 Ford Fiesta 1.4 | 2003 Fiat Palio 1.9
      2002 Hero Honda CBZ | 2002 Ford Ikon 1.6 | 1998 Ford Escort 1.8

    Page 4 of 4 FirstFirst ... 234

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Where to fix the perfume in the car
      By shravank30 in forum Bodywork & Interiors
      Replies: 20
      Last Post: 29th May 2014, 11:37
    2. Replies: 8
      Last Post: 12th Dec 2012, 08:55
    3. Ikon A/C Issues
      By jaguar in forum Ikon
      Replies: 5
      Last Post: 5th Apr 2010, 00:23
    4. Few of my Quick Fix Restorations
      By PAVAN KADAM in forum Vintage & Classics
      Replies: 15
      Last Post: 12th Nov 2009, 08:59

    Tags for this Thread

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •