• Angry
  • Awesome
  • Hungry
  • Secret
  • Results 1 to 6 of 6

    Thread: Ignition Issues with Ford Fiesta 2006 1.4 Tdci

    1. #1

      Its better to burnout then
      fade away
       
      Awesome
       
      ashishkumar's Avatar
      Join Date
      Jul 2013
      Location
      New Delhi
      Posts
      14

      Ignition Issues with Ford Fiesta 2006 1.4 Tdci

      Hi, I just came back from Delhi-Manali-Solang-Kasol-Delhi Trip around 1200 Kms with no major issues with my Ford Fiesta. The problem which I faced was that the car wont start. It gives a Click sound when you try starting the car. The car starts when you use some hands but does not self start. Got it checked at Gyani Motorworks, Manali but they weren't able to diagnose the exact issue. Changes some Switches and Carbon Plate which I have no idea if its a part of the car. Car worked since yesterday without an issue but again tonight it wont start. Will be taking to the ASS this weekend but any advices will be appreciated .

      thanks in advance

    2. #2

      Forget and forgive. Live and
      let live. Learn and learn to
      share
       
      Awesome
       
      Simple_car's Avatar
      Join Date
      Jul 2013
      Location
      Ban-land!
      Posts
      909
      Quote Originally Posted by ashishkumar View Post
      It gives a Click sound when you try starting the car. The car starts when you use some hands but does not self start.
      If the lights come on the dash:
      - and are you getting a click..click..click sound when you try and start the car? If so, your starter motor is most likely at fault. Try and just hit the motor with a stick; and then start the car.
      - and there is no click..click sound: either the starter motor is at fault (more likely) or your ignition switch is burnt out.
      - if starter motor is churning over but the engine is not firing: engine is not getting enough fuel (can be due to clogged fuel lines).

      If the lights do not come on the dashboard:
      - battery is kaput or
      - a loose connection
      - maybe a blown fuse (less likely in your situation).

      Other things that can be wrong:
      - possible bad fuel that might have clogged the fuel filter.
      - possible range of engine issues (once the car is fired up, is your engine making any abnormal sounds?)
      - I think I have run out of things that I can think of..

      Keep us updated.

      Thanks,
      Simple_car

    3. #3

      Its better to burnout then
      fade away
       
      Awesome
       
      ashishkumar's Avatar
      Join Date
      Jul 2013
      Location
      New Delhi
      Posts
      14
      There are lights in the Dashboard, and didn't noticed any abnormal sounds from the engine. I will get it serviced this weekend and will also run a full diagnostics. thanks

    4. #4

      In Bhai we Trust
       
      Hungry
       
      WildWeasel's Avatar
      Join Date
      Sep 2010
      Location
      Melbourne/AU
      Posts
      5,105
      Check if the battery terminals are tight. Might sound silly, but things happen.

    5. #5

      Sex is not the Answer. Sex is
      the Question. Yes is the
      Answer
       
      Awesome
       
      Indian's Avatar
      Join Date
      Mar 2013
      Location
      Norway
      Posts
      3,648
      Try to press the horn button with the headlights on. If it sounds normal, you are fine with the battery. Otherwise it could be loose leads from the battery to the starter motor. Check both ends. If they are tight, put the car in free, ignition on and short the spade connector on the starter motor to ground. If it starts, you have a problem with the ignition switch and if not, you have a faulty starter motor.

    6. #6

      Its better to burnout then
      fade away
       
      Awesome
       
      ashishkumar's Avatar
      Join Date
      Jul 2013
      Location
      New Delhi
      Posts
      14
      The problem got fixed this Saturday, There was a problem with the Starter Motor switch and got it changed at the local mechanic and now the car runs like a kitten. Thanks all for your help.

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Replies: 18
      Last Post: 19th Apr 2013, 14:12
    2. Replies: 3
      Last Post: 17th Feb 2013, 07:29
    3. ABS Warning Lamp ON in Ford Fiesta 1.4 TDCI
      By raj_hyd in forum Fiesta
      Replies: 15
      Last Post: 5th Jan 2013, 14:54
    4. Ford Fiesta 2006 ZXI TDCI for Sale.
      By Nitinralli in forum Sold Items / Closed Trades / Completed Deals
      Replies: 0
      Last Post: 27th Jul 2012, 16:18
    5. My take on the Ford Fiesta 1.4 TDCi
      By Silver Knight in forum Fiesta
      Replies: 3
      Last Post: 16th Jul 2011, 14:23

    Tags for this Thread

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •