• Angry
  • Awesome
  • Hungry
  • Secret
  • Results 1 to 9 of 9

    Thread: Linea stalls after starting. What could it be?

    1. #1
      love to drive thanks to
      wonderfully sounding system.
      Thanks Gearheads.
       
      Awesome
       

      Join Date
      Jul 2010
      Location
      Delhi
      Posts
      397

      Linea stalls after starting. What could it be?

      Hi.


      I recently bought a linea emotion diesel, used, mid showing 48,000.


      The car's alternator's pulley broke off last wednesday. I had to get the alternator replaced.


      Now, on Monday, I drove the car for about 15 kms. Thereafter, parked the car outside a school, in the sun.


      When I came back, about an hour later, the car started normally, but immediately fluttered and died. At the same time, the mid started showing check engine light.


      The car had to be towed to Torque fiat, gurgaon.


      The people there diagnosed it as failed alternator, and replaced it. But the problem persisted. Then they attached the diagnostic tool, and told me that the fault codes identified were: EGR failed, ECU fault, mass filter error.


      My query is, what could the reason be for the stalling of the car after it starts absolutely fine.

    2. #2
      ~~Wandering Soul~~
      by the power of Grayskull
       
      Secret
       
      kane's Avatar
      Join Date
      Mar 2014
      Location
      Mumbai ( Bombay)
      Posts
      1,381
      EGR Valve Failure and the Mass Air flow sensor could be bad, the ECU of you car is shutting down the engine due to these two failures to prevent damage.


      http://www.ehow.com/about_5790592_eg...-symptoms.html

      http://www.airmassmeterspecialists.c...asp?ID=1081845
      Last edited by kane; 9th Apr 2014 at 11:43. Reason: Added Explanation links

    3. #3
      love to drive thanks to
      wonderfully sounding system.
      Thanks Gearheads.
       
      Awesome
       

      Join Date
      Jul 2010
      Location
      Delhi
      Posts
      397
      The fault code given by the diagnostic tool is P02146-condenser voltage present

    4. #4
      ~~Wandering Soul~~
      by the power of Grayskull
       
      Secret
       
      kane's Avatar
      Join Date
      Mar 2014
      Location
      Mumbai ( Bombay)
      Posts
      1,381
      P02146 is for incorrect current for injector goup 1, injectors 1 and 4.

      My advice would be to ask for assistance from gearheards to guide you to a reliable workshop to diagnose and rectify your problem without anyone actually ripping you off.
      Do note my assistance is only on the error codes and what it means

    5. #5
      love to drive thanks to
      wonderfully sounding system.
      Thanks Gearheads.
       
      Awesome
       

      Join Date
      Jul 2010
      Location
      Delhi
      Posts
      397
      So, the ECU is not faulty here? The Service advisor told me they had fitted the injectors on another linea and it was working fine. Does it mean I have to take the car to another mechanic from Authorised Fiat Service Station?

    6. #6

      On the lookout for more 4
      wheel victims.
       
      Hungry
       
      tadukuttan's Avatar
      Join Date
      Oct 2009
      Location
      Bangalore
      Posts
      4,997
      Quote Originally Posted by deepfusion View Post
      So, the ECU is not faulty here? The Service advisor told me they had fitted the injectors on another linea and it was working fine. Does it mean I have to take the car to another mechanic from Authorised Fiat Service Station?
      All the errors were in all probability caused by the mis behaving alternator. Random voltage changes in the system can throw most systems in the car out of whack.

      If the car is running fine after the alternator replacement, then you should be good to go. Is the car fine after the alternator replacement? If it is not fine, what are the error codes you are seeing now? Also try a clear, and then let us know the "new" codes that turn up post a clear.
      In pursuit of happiness, and happiness drives very fast.

    7. #7
      love to drive thanks to
      wonderfully sounding system.
      Thanks Gearheads.
       
      Awesome
       

      Join Date
      Jul 2010
      Location
      Delhi
      Posts
      397
      Quote Originally Posted by tadukuttan View Post
      All the errors were in all probability caused by the mis behaving alternator. Random voltage changes in the system can throw most systems in the car out of whack.

      If the car is running fine after the alternator replacement, then you should be good to go. Is the car fine after the alternator replacement? If it is not fine, what are the error codes you are seeing now? Also try a clear, and then let us know the "new" codes that turn up post a clear.
      The alternator was initially replaced last Wednesday and the car ran for about 400 kms thereafter before this happened.

    8. #8
      Global Moderator
      At wits end with Safari's
      auto-correct!
       
      Awesome
       
      kb100's Avatar
      Join Date
      Oct 2009
      Location
      Duffai!
      Posts
      6,009
      Like tadu said - clear all codes and see if it throws up an error again. If it does, your new alternator might need replacing (or the chain will need investigating.. the regulator and the likes)
      A closed mouth gathers no feet.

    9. #9

      On the lookout for more 4
      wheel victims.
       
      Hungry
       
      tadukuttan's Avatar
      Join Date
      Oct 2009
      Location
      Bangalore
      Posts
      4,997
      deepfusion Clear the codes, run again. Post what turns up. And if you dont have an OBD2 apdapter, procure it so that you can clear codes yourself.
      In pursuit of happiness, and happiness drives very fast.

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Replies: 183
      Last Post: 8th Jun 2016, 14:09
    2. engine stalls while breaking
      By nikilkiran in forum Esteem
      Replies: 3
      Last Post: 9th Jul 2013, 15:36
    3. Starting my journey.
      By noble in forum Introduce Yourself
      Replies: 16
      Last Post: 20th Dec 2012, 19:03
    4. Baleno starting Issues
      By Masheq in forum Introduce Yourself
      Replies: 5
      Last Post: 28th Feb 2011, 06:44

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •